How to run in .NET 3.5

Nov 22, 2010 at 6:53 PM

I tried convert MusicStore to .NET 3.5 and changed it to my database schema and linq to sql:

1. Added <add namespace=System.Collection.Generics> to web.config

2. Changed <:  to <=

Now I'm getting runtime error in CartSummary.ascx

at line

<%@ Control Language="C#" Inherits="System.Web.Mvc.ViewUserControl<dynamic>" %>

error CS0246: The type or namespace name 'dynamic' could not be found (are you missing a using directive or an assembly reference?)

How to fix this? How to convert MusicStore to .NET 3.5 ? If this is not possible, where to find MVC shopping cart sample code which works in .NET 3.5 ?

Andrus.

Sep 2, 2011 at 3:13 PM

Hello! Have you found that shopping cart sample code for LINQ to SQL by any chance?

Coordinator
Sep 2, 2011 at 10:02 PM

ASP.NET MVC 3 requires .NET 4. If you want to run under .NET 3.5 you'll need to stick with with the 1.0 version of MVC Music Store, which targeted MVC 2.