Cannot load ASP.NET Configuration website

Oct 6, 2010 at 3:03 PM
Edited Oct 7, 2010 at 4:56 AM

I have reached page 65 of the tuorial. The Account Controller/Model/View files have been copied in to the project folder and added to the project.

When I click the icon in Solution Explorer, the website opens, but when I click the Security tab, I get error: "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified" I clicked the Provider tab and nothing works there too.

I have included the ASPNETDB.MDF from the sample project. But as I am strictly following the tutorial, I am not sure, why the Config site is not working. Please help.

Am I expected to create the Membership, Profile and RoleManager nodes in web.config manually? Do I create the ASPNETDB.MDF from scratch using aspnet_regsql.exe? I am under the impression that because the tutorial doesn't mention it, the VS2010 wizardry might be working behind the scenes.


- Tushar G. Walavalkar

Oct 7, 2010 at 7:13 AM
Edited Oct 7, 2010 at 7:17 AM

On Page 64, in addition to the various copy tasks done from your temp project to your Store project, you also need to copy the <membership>, <profile> and <rolemanager> nodes from the temp project web.config. You will also have to copy the connection string or create a new one for use with the providers. From what I infer, these providers as yet cannot use the EF provider connection string. May be someone can correct me here.


Tushar G. Walavalkar

Mar 2, 2011 at 10:19 AM

I had similar issue. I have followed your instructions and it is working for me now. Thanks for the post.

I copied <membership>, <profile> and <rolemanager> nodes from the temp project web.config to my MvcMusicStore project web.config

I had to create a new ASPNETDB database in my sql server and run the aspnet_regsql utility to populate that. Then I had to add the connectionstring in web.config file as below,

<add name="ApplicationServices"connectionString="Server=localhost\instance2;Database=ASPNETDB;Trusted_Connection=True;"providerName="System.Data.SqlClient"



Mar 2, 2011 at 10:19 AM
Edited Mar 2, 2011 at 10:19 AM



Mar 3, 2011 at 2:03 PM

It feels great to know that somebody benefited from my post. Thank you.

Mar 4, 2011 at 8:58 PM

Remember that is a new project with framework MVC, the functionalityis diferent.