Visual studio crashes following the tutorial

Jun 8, 2011 at 10:08 PM

Hello everyone,

I looked at the discussions, apparently I am the only one (for the moment) concerned about this problem.

Here the details :

1 - I am using visual studio 2010

2-  I installed MVC 3 plugin (downloaded from microsoft web site) because it was not included with the visual studio 2010

3 - I am following the tutorial Version  3.0b (4/28/2011)

4- On page 24, i tried to add my first view by right clicking within the index action method in the HomeController.cs

==> Visual studio crashes ...

Problem Details

Problem signature:
  Problem Event Name:    APPCRASH
  Application Name:    devenv.exe
  Application Version:    10.0.30319.1
  Application Timestamp:    4ba1fab3
  Fault Module Name:    kernel32.dll
  Fault Module Version:    6.1.7601.17514
  Fault Module Timestamp:    4ce7baf9
  Exception Code:    c0000005
  Exception Offset:    0001139d
  OS Version:    6.1.7601.2.1.0.256.1
  Locale ID:    2057

Additional information about the problem:
  LCID:    1033

In fact, it craches everytime I double-click some elements in the view folder.

Any ideas ? I'd really like to finish this tutorial :)

Thanks a lot

T.

 

Coordinator
Jun 11, 2011 at 6:57 AM

I haven't seen that before, and it's definitely not expcted. Can you make sure you've got the prerequisites correctly installed? The best way to do that is to install the WebPI package from http://www.microsoft.com/web/gallery/install.aspx?appid=VWDorVS2010SP1Pack

Jun 14, 2011 at 10:42 AM

Hi,

Thanks for the tip. I built up a virtual machine :

- Same O.S

- Same anti virus config

- Same visual studio express version without SP1

I installed MVC3 using the link you have given and it works !!!

I think the problem was that I had installed SP1 directly as a stand alone package. It's kind of weird to not be able to install packages separately

Anyway, thanks a lot

T.