Error:Unable to find the requested .Net Framework Data Provider. It may not be installed.

Oct 27, 2011 at 6:47 AM


 I have downloaded the MVC3 example of Music Store.But when i try to run the Same example on my System i get the error.Error:Unable to find the requested .Net Framework Data Provider.  It may not be installed.

What changes do i have to make to make it work on my system.There is no issue of Connection String I guess,I also have Sql Express.

Please Suggest.

Oct 29, 2011 at 7:05 PM

Both SQL Server Compact and SQL Server Express are required for this release - it'll hopefully be changed on the next release, but the application code use SQL Server Compact while the ASP.NET Membership system requires SQL Server Express.

The installation prerequisites section should have made sure you had both databases installed, but you can get SQL Server Compact two ways:

May 26, 2012 at 6:48 PM


I was able to solve the same problem:

However, I have a similar MVC 2 project and it is working just fine without applying this. Not sure if this is related with MVC 3 only.