Unable to find the requested .Net Framework Data Provider. It may not be installed.

May 5, 2012 at 8:20 PM

I am working with MVCMusicStore App but i am getting error while running the application.

i.e. Unable to find the requested .Net Framework Data Provider.  It may not be installed.  

the above error is coming when i make a request to http://localhost:1040/Store

could anybody resolve this problem?

May 7, 2012 at 1:46 AM

I have the same issue.

Any help would be appreciated.

[ Visual Studio 2010 - SP1Rel // .NET Framework 4.0.30319 ]

Coordinator
May 7, 2012 at 1:51 AM

This is usually due to not having the prerequisites installed. See the "Installing the software" section here: http://www.asp.net/mvc/tutorials/mvc-music-store/mvc-music-store-part-1

There are some earlier discussions with the same question, e.g. http://mvcmusicstore.codeplex.com/discussions/277370

Let me know if you still see this error after verifying that you've got the required software installed.

- Jon

May 7, 2012 at 5:56 AM

I've installed all the pre-requisites and I still get the same error. 

Coordinator
May 7, 2012 at 6:15 AM

Can you run the completed application code (included in the main download at http://mvcmusicstore.codeplex.com/) and see if you get the same error? That will let us know if the problem is in your application's code or if it's a problem with installed software.


From: dego [notifications@codeplex.com]
Sent: Sunday, May 06, 2012 9:56 PM
To: Jon Galloway
Subject: Re: Unable to find the requested .Net Framework Data Provider. It may not be installed. [mvcmusicstore:354646]

From: dego

I've installed all the pre-requisites and I still get the same error.

May 7, 2012 at 6:21 AM

I did run the completed code and the same error occurs

Coordinator
May 7, 2012 at 6:23 AM

Can you try running the Web Platform Installer for VS2010 SP1? It should check to make sure you've got the necessesary prereqs: http://www.microsoft.com/web/gallery/install.aspx?appid=VWDorVS2010SP1Pack


From: dego [notifications@codeplex.com]
Sent: Sunday, May 06, 2012 10:21 PM
To: Jon Galloway
Subject: Re: Unable to find the requested .Net Framework Data Provider. It may not be installed. [mvcmusicstore:354646]

From: dego

I did run the completed code and the same error occurs

May 7, 2012 at 5:02 PM

Ive installed  Web Platform Installer for VS2010 SP1 twice. Any suggestions are appreciated.

May 26, 2012 at 7:08 PM

I was able to solve the same problem:

http://stackoverflow.com/questions/6508516/asp-net-mvc-3-unable-to-find-the-requested-net-framework-data-provider

However, I have a similar MVC 2 project and it is working just fine without applying this. Not sure if this is related with MVC 3 only.

May 29, 2012 at 3:38 PM

Thank you so much jemunsayac. That worked!

Jun 20, 2012 at 8:36 AM
Edited Jun 20, 2012 at 8:37 AM

Thanks you so much jemunsayac...it worked!